Illumina Connected Insights Service Degradation

Incident Report for Illumina Cloud Products

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 17:27 UTC

Monitoring

System is functional now. We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 22:25 UTC

Investigating

ICI case uploads using the ICI Uploader may see slowness in data upload and case ingestion
Posted Oct 20, 2025 - 18:25 UTC
This incident affected: USA (Illumina Connected Insights - US East).