Illumina Connected Analytics Flow Service Degradation - USA

Incident Report for Illumina Cloud Products

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 18:53 UTC

Monitoring

ICA experienced a service degradation in the US region for Flow analyses between 4/13/2025 22:00PM PST and 4/14/2025 11:00 PST.

Incomplete analyses in statuses other than "Accepted" during the service degradation period are impacted and will appear stuck in their current status. This issue is under active investigation.
Posted Apr 14, 2025 - 18:46 UTC
This incident affected: USA (Illumina Connected Analytics - US East).