Dragen Apps and Content Degradation - Global

Incident Report for Illumina Cloud Products

Update

As the deadline gets closer we have started disabling the deprecated apps based on their recent usage. Please reach out to techsupport@illumina.com if you have any questions.
Posted Nov 18, 2025 - 01:31 UTC

Update

We are continuing to investigate this issue.
Posted Oct 28, 2025 - 22:23 UTC

Investigating

DRAGEN is retiring several older applications due to limited AWS availability. Users may experience longer wait times when using these legacy apps. To ensure optimal performance and reliability, we strongly encourage transitioning to the latest versions. Many of the new apps are fully compatible with the older apps. Please see our Obsolescence Notices for details.
Posted Oct 28, 2025 - 22:22 UTC
This incident affects: Global (Dragen Apps and Content - Global).