BaseSpace Sequence Hub Service Degradation - India
Incident Report for Illumina Cloud Products
Resolved
We are currently experiencing a service degradation and are actively trying to resolve the issue. Please keep monitoring this page for updates or contact Technical Support at techsupport@illumina.com.
Posted Nov 18, 2024 - 19:26 UTC
Investigating
We are currently experiencing a service degradation and are actively trying to resolve the issue. Please keep monitoring this page for updates or contact Technical Support at techsupport@illumina.com.
Posted Nov 18, 2024 - 19:11 UTC
This incident affected: India (Basespace Sequence Hub - Mumbai).