BaseSpace Sequence Hub Service Degradation - United States

Incident Report for Illumina Cloud Products

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 23:10 UTC

Investigating

We are currently experiencing an issue preventing some analyses from successfully completing. Please don't cancel and requeue running analyses, and keep monitoring this page for updates or contact Technical Support at techsupport@illumina.com.
Posted Sep 05, 2025 - 19:56 UTC
This incident affected: USA (Basespace Sequence Hub - US East).