BaseSpace Sequence Hub Service United States - Active Monitoring in Progress

Incident Report for Illumina Cloud Products

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 18:04 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 02:06 UTC

Update

Issues with our cloud service provider are largely resolved. We are seeing longer than usual delays for some apps as the queues clear.
Posted Oct 20, 2025 - 20:49 UTC

Update

Issues with our cloud service provider continue but are improving. In an abundance of caution we recommend not starting new runs or analyses until further notice. Do not cancel any apps or sequencing runs already in progress.
Posted Oct 20, 2025 - 19:16 UTC

Monitoring

Some apps may be Queued for Analysis longer, or fail more frequently, due to issues with our cloud service provider. Please keep monitoring this page for updates.
Posted Oct 20, 2025 - 16:34 UTC
This incident affected: USA (Basespace Sequence Hub - US East).