Illumina Connected Insights - Access Issues

Incident Report for Illumina Cloud Products

Resolved

Issue has been resolved. There was a configuration issue which has been fixed now.
Posted Jul 22, 2026 - 22:38 UTC

Investigating

We are experiencing issues with Illumina connected Insights where user is not able to select workgroup and login to the application. We are actively working on the fix.
Posted Jul 22, 2026 - 21:42 UTC
This incident affected: Australia (Illumina Connected Insights - Sydney), Canada (Illumina Connected Insights - Canada), South Korea (Illumina Connected Insights - Seoul), Germany (Illumina Connected Insights - Frankfurt), United Kingdom (Illumina Connected Insights - London), and USA (Illumina Connected Insights - US East).