Illumina Connected Analytics Service Degradation

Incident Report for Illumina Cloud Products

Resolved

This incident has been resolved.
Posted Sep 17, 2026 - 00:16 UTC

Monitoring

AWS has resolved their service availability issues, and we will continue to monitor the results.
Posted Sep 16, 2026 - 19:54 UTC

Investigating

We are currently experiencing a service degradation due to an underlying AWS Service availability in Israel, and are actively trying to resolve the issue. Please keep monitoring this page for updates or contact Technical Support at techsupport@illumina.com.
Posted Sep 16, 2026 - 15:42 UTC
This incident affected: Israel (Illumina BioInsight Platform Core - Tel Aviv).