Illumina Connected Analytics Service Degradation - USA

Incident Report for Illumina Cloud Products

Resolved

Going forward, ICA Flow issues like this will now be tracked under "DRAGEN Apps and Content" component under the Global region, as they typically affect multiple products within our suite.
Posted Oct 29, 2025 - 20:29 UTC

Update

ICA Flow is currently operating at reduced capacity due to upstream issues with AWS. We are actively engaged with AWS and working towards a resolution.

Customers will still be able to process data in ICA flow, albeit at reduced capacity. If you have any questions, please contact Technical Support at techsupport@illumina.com.
Posted Oct 29, 2025 - 05:05 UTC

Investigating

We are currently experiencing an outage affecting AWS services, and as a result Flow is currently unavailable in the US East (N. Virginia).

Please refrain from aborting and/or rerunning analyses in this region. Please keep monitoring this page for updates or contact Technical Support at techsupport@illumina.com.
Posted Oct 29, 2025 - 02:40 UTC
This incident affected: USA (Illumina Connected Analytics - US East).