Illumina Connected Insights Service Degradation - All Regions

Incident Report for Illumina Cloud Products

Resolved

This incident has been resolved and the incident is now closed. Please contact Technical Support at techsupport@illumina.com if you have any further questions.
Posted Mar 27, 2025 - 08:42 UTC

Update

We are continuing to investigate this issue.
Posted Mar 27, 2025 - 05:32 UTC

Investigating

We are currently experiencing a partial outage with Illumina Connected Insights and are actively trying to resolve the issue. User login is not working at the moment. Please keep monitoring this page for updates or contact Technical Support at techsupport@illumina.com.
Posted Mar 27, 2025 - 05:31 UTC
This incident affected: Australia (Illumina Connected Insights - Sydney), Canada (Illumina Connected Insights - Canada), South Korea (Illumina Connected Insights - Seoul), Germany (Illumina Connected Insights - Frankfurt), United Kingdom (Illumina Connected Insights - London), and USA (Illumina Connected Insights - US East).