Availability issues in us-east-1 region for BaseSpace Sequence Hub

Incident Report for Illumina Cloud Products

Resolved

From 4:47pm PDT to 6:50pm PDT we experienced an availability degradation due to an underlying AWS Availability Zone outage. We redeployed affected infrastructure outside of the AZ and recovered. Everything is now operating normally
Posted May 08, 2026 - 03:36 UTC

Update

We are continuing to investigate this issue.
Posted May 08, 2026 - 01:48 UTC

Update

We are investigating availability issues for customers in us-east-1 region due to an underlying AWS instance issue.
Posted May 08, 2026 - 00:54 UTC

Investigating

We are investigating login issues for customers in us-east-1 region
Posted May 08, 2026 - 00:35 UTC
This incident affected: USA (Basespace Sequence Hub - US East).