BaseSpace Sequence Hub Service Degradation - USA
Incident Report for Illumina Cloud Products
Resolved
Operational: We are now running at full capacity
Posted Mar 04, 2024 - 04:51 UTC
Monitoring
Operational - Service has been restored, but we are continuing to monitor the situation
Posted Mar 03, 2024 - 02:36 UTC
Identified
We are currently experiencing a service degradation and are actively trying to resolve the issue. Please keep monitoring this page for updates or contact Technical Support at techsupport@illumina.com.
Posted Mar 02, 2024 - 01:12 UTC
This incident affected: Basespace Sequence Hub - US East.