Investigating issue with BaseSpace Sequence Hub - US East
Incident Report for Illumina Cloud Products
Resolved
This incident has been resolved.
Posted Apr 20, 2024 - 15:49 UTC
Update
We are continuing to investigate this issue.
Posted Apr 20, 2024 - 15:49 UTC
Investigating
We are currently investigating this issue.
Posted Apr 20, 2024 - 12:05 UTC
This incident affected: Basespace Sequence Hub - US East.